Installation Notes - New user

Dear Chip and Creare ,
I’m trying to get software installed to try out Tympan!
I hope these notes will make it easier to prepare instructions for other novices to get started.
I’m running Windows 10 (unfortunately) on a Surface Pro 4

  1. The Arduino IDE installed fine, following your instructions. Clicked on the shortcut - all is well.

  2. When I tried to install the Teensy Add-on, I get this message:
    “Windows 10 USB Serial Driver found.
    No driver installation required.”
    (It then asks for a folder for installation, but the ‘Next’ button is gray…so no installation happens.)
    I’ll try to continue…

  3. Next problem (Note that I’m not an experience github user)
    I clicked on “Clone and Download” on the Tympan library site, and then “Download zip”.
    When I tried to unzip this into the /Arduino/library folder, I get the following error from Winzip:
    "Unable to Process
    Then a message appears:
    "WinZip was able to extract only part of the file because it contains invalid or missing data.
    Would you like to keep the partial file?
    (Note the partial file will be named CORRUPT.)."
    It asks me to continue…but then I get the same error on the next file, and three others. Forging ahead…

I went ahead and connected the hardware to my USB port.
Started up the Arduino IDE, but under “Tools” and “Board” there is no
"Teensy 3.6" option (probably because of the problems above.)
There is also no entry under the “Tools” menu for “USB Type” (only “Port”) and “Serial + MIDI + Audio” isn’t an option.

The hardware seems to come up in “pass through” mode, and sounds good. But I’m completely stuck on trying to work with the software.
Any advice would be appreciated.
Laurel Carney

Hi Laurel,

Thanks so much for giving it a go! It looks like you have two issues:

A) As you said, you got stuck during the installation of the Teensy add-on. Unluckily for you, Arduino just released a new version of the Arduino IDE (this past weekend) and it sometimes takes a few days for the Teensy folks to come out with a corresponding update. Unfortunately, you might be right in the middle between those two events…stuck.

To see if this is the problem, could you tell me the version number of your Arduino IDE? (start the Arduino IDE, go under “Help” menu, and choose “About”. It should be listed in the top left of the window)

B) The downloading of the ZIP appears to be corrupted. You may need to re-download the zip. Without the Teensy Add-on, however, it won’t do you any good. So, let’s fix the Teensy Add-on first.


To more fully expand on item (A) above, the latest Arduino IDE is 1.8.3. To see if the latest Teensy Add-on is compatible with 1.8.3, I went to the Teensy download page:

where it says (as of Jun 7, 2017): “Teensyduino 1.36 supports Arduino versions 1.0.6 and 1.6.5-r5 and 1.6.9 and 1.6.12 and 1.6.13 and 1.8.1 and 1.8.2.” Note that it does not yet support 1.8.3 as Teensyduino 1.36 must pre-date 1.8.3.

So, if you have Arduino 1.8.3, this is probably what’s preventing you from installing the Teensy Add-on. If this is your problem, you can either download an older version of the Arduino IDE (such as 1.8.2) or you can download the latest beta version of the Teensy Add-on (which does support Arduino 1.8.3). You can get the beta here:

Of these two options, I’d probably choose to install the Teensy beta. But, in full disclosure, I’ve not actually tried either of the approaches for these latest versions. I’ll try to give them a try at the end of the day today.


Thanks for your response. The beta version of the Teensy Add-on successfully installed, so that’s one battle won. Now the indicated options under “Tools”, “Board”, and “USB port” all appear when I run the Arduino code.
In the display of the Arduino “sketch” panel, it says “Invalid library found in C:\Program Files (x86)\Arduino\libraries\Tympan_Library” This is not surprising, given that I was still not able to unzip a (newly downloaded) version of the Tympan Library. I tried again to unzip it into the /Arduino/library folder, using a new folder I created there, called Tympan_Library. No luck - it seemed that even more “Corrupt” file warnings came up this time, and the folder ends up empty.
Any suggestions for my next try? Thanks, Laurel

Maybe it’s something in the download/browser that’s causing the ZIP to not complete its downloading? Weird.

I just emailed you the ZIP directly. Please let me know if that worked.


Success!! - Here are a couple of notes for future new/installing users:

  1. Make sure the “Teensy” download is compatible with the version of the Arduino IDE that is downloaded! As Chip discerned, the Arduino IDE I downloaded had just been updated, which caused incompatibility with the Teensy download, which was just a tick behind. Easily resolved once he pointed out the issue, and directed me to a compatible version of Teensy.
  2. The Tympan_Library Zip couldn’t be unzipped right into the Arduino/library folder, due to some permissions issues in the midst of the Arduino folders. Unzipping Tympan_Library into a Desktop folder, and then copying that folder into the Arduino/library folder did the trick.
  3. The directions for running Basic Example are easy to follow - Only one suggestion: On my machine, the Arduino/Teensy “Sketch” window that pops up is quite small. I didn’t realize how much I was missing on my first time through the examples! Enlarge the window to see lots of information! (e.g. the “Change Sample Rate” example only makes sense when you enlarge the window. Then you can see the code, change the rate, re-compile, and you’re good to go. This is a simple, but empowering, example!)
    I’ve just gone through all of the “Basic” example. The sound quality is fantastic. Eager to start working with further examples. Thanks for all the help during start-up! -Laurel

Following the instructions provided with the Tympan unit, I found installation of the software Arduino software and Teensy add-on to be straightforward. I had downloaded an earlier version of the Arduino software (1.8.2) so I did not experience some of the difficulties others had reported, which seemed to be related to an updated version (1.8.3) of the software. I installed the software on two desktop computers running Windows 7 and two laptops running Windows 10. I was initially unsure about how to add the Tympan library, but I was able to figure this out by going to the Arduino website. I learned that it was best to add the zip file using the software, rather than copying the unzipped files to the Arduino library folder. I was also easily able to set my preferences for the location of the Arduino library folder since I do not prefer to clutter up the ‘My Documents’ folder, which is the default location. I learned that I could even rename the library folder in Windows Explorer (“Tympan_Library-master” to “Tympan_Library” or “Tympan”) and the software would automatically update the association.

I was able to connect the Tympan Unit and watch the Serial Monitor as I adjusted the volume knob, so I knew that everything was connected and installed right. However, for some reason I could not get any of the example programs to compile and ‘upload,’ despite trying multiple things. I would get a long error message that can be summed up by “‘AudioInputUSB’ does not name a type.’ I initially thought that I had installed the Tympan library incorrectly, so I kept trying different things with the library folder to see if that would make a difference. It turns out that for ‘USB Type’ in the ‘Tools’ menu, I had chosen “Serial” instead of “Serial + MIDI + Audio.” This is shown in the figure below.

In addition, for my desktop installations running Windows 7, I was given an option to choose a Port within the “Tools” menu. However, as shown by the red arrows in the figure, for my laptop installations running Windows 10, this option was grayed out. I spent some amount of time trying to figure this out and checked my Windows Device Manager several times before I found a detailed support page on the Arduino website that made various recommendations like turning off any Bluetooth ports and exiting from virtual DVD software. It turned out in the end that it did not make a difference and that I could upload a program to the Tympan unit despite what I thought was a problem. For some reason, when I connected the device at a later time, the COM port for the Teensy board showed up, despite the fact that I did not shut down any other programs running in the background (see figure).