Codec shield with Tympan Rev E

I am trying to use the codec shield with a Tympan Rev E. I started with the examples in the examples/09-AIC_Shield folder but have not been able to get any to work. No sound is captured from the microphone jack or sent to the headphone jack.

The examples all seem to be written for Rev D. I tried adding a TympanRev::E argument to the Tympan and AICShield constructors and that eliminated some error messages but there is still no sound. Does anything else in the code need to be updated to use the shield with Rev E?

Is there any way to tell whether the shield is connected properly? The pins do not seem to fit very well in the socket. I tested the pins with a multimeter and they seem to be connected, but I can’t rule out a poor connection.

You’re right! The examples do look out-of-date. I’m on it!


1 Like

Here’s what the myTympan and aicShield lines should look like:

Tympan      myTympan(TympanRev::E, audio_settings); 
AICShield   aicShield(TympanRev::E, AICShieldRev::A);   

I’ll be updating all the examples shortly to include this revision.

Strangely, though, on my RevE with AICShield this worked the first time that I ran it but it hasn’t worked the subsequent times that I’ve tried to run it. It is not making any audio. I don’t know why. Weird. So, I’m still digging.

I fixed the underlying AICShield class. I’m not sure why it stopped working but I definitely made some improvements.

I also edited all of the AICShield examples to include the revised two lines above. In my testing, it seems to work for both RevD and RevE.

If you update your Tympan_Library, the AICShield examples should hopefully work for you too!

Let me know!


It is working for me now. Thank you so much for the quick fix!